DIGICHIEF SERVICE DISRUPTION

Incident Report for DIGICHIEF

Resolved

All API services are working as should. We will continue to monitor for any additional disruptions.
Posted Oct 20, 2025 - 13:39 UTC

Monitoring

Our cloud provider, AWS, experienced a significant outage overnight. The core issue has been resolved but some services continue to experience temporary delays as systems recover. We are monitoring performance closely and will provide updates as the backlog clears.
Posted Oct 20, 2025 - 11:31 UTC

Investigating

We are aware of service disruptions for our content APIs due to an outage at AWS. We are continuing to monitor and will provide updates when the issues are resolved.
Posted Oct 20, 2025 - 11:00 UTC
This incident affected: STOCKS (Stock quotes), NEWS HEADLINES (News Headlines, Soft News), TRANSPORTATION (Transit, Traffic, Flights), INFOTAINMENT (Birthdays, Famous Quotes, Fun Facts, Holidays, Horoscope, Jokes of the Day, This Day In History, Trivia), SPORTS SCORES (Scores, Stats), WEATHER (Weather Forecast & Conditions, Weather Map Imagery, Pollen), and LOTTERY, MERCURY WIDGET PLATFORM.