DIGICHIEF Weather API Maintenance

Scheduled for May 8, 07:00 - 07:10 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted May 19, 2025 - 14:47 UTC

Scheduled

We will be updating our Weather API starting Thursday (5/8/24) at 2am ET. No significant downtime is expected.
Posted May 06, 2025 - 14:41 UTC
This scheduled maintenance affects: WEATHER (Weather Forecast & Conditions).